Author Topic: Hesitation in my 2002 Impreza 2.5RS  (Read 2373 times)

Offline PhamilySedan

  • Elite Member
  • *****
  • Posts: 1349
    • http://www.nebraska-subaru.com
Hesitation in my 2002 Impreza 2.5RS
« on: February 23, 2012, 09:41:00 PM »
Hey fellow NSOC'ers, 

I've been trying to tackle this problem for a LONG time now.  Since about November my car has been sitting because it's been giving me these two problems.  The first problem was that I was leaking oil through my spark plug gaskets.  I just re-did the valve cover gaskets and spark plug gaskets as well as brand new spark plugs today. 

The real problem lies hear.  On a cold or warm start,  the car will idle just fine until a few seconds or a minute passes and then the idle gets REAL rough.  Sounds as if it has a HUGE cam in it haha  It won't die but it does a real steady hard idle.  If you count "one" then "two" real slow, that's about how rough it idles.  Also, this is probably related to the idle issue.  When I accelerate the car bogs/bucks hard.  For example, if i'm at lets say 3K RPM, and i'm trying to get it to 4K RPM, it'll start bucking/bogging anywhere inbetween until it reaches a higher RPM.  (Not at any certain RPM but at any random RPM)   I'm thinking that this might be a bad O2 Sensor? 

I thought that the bad spark plug gaskets were causing the misfire, but nothing has changed after I replaced those today.  Any help would be greatly appreciated because I miss driving her haha  C'mon guys help me out!   :subaru:
« Last Edit: February 23, 2012, 09:43:22 PM by PhamilySedan »

"Yet another reason I wish I was rich. I would own Crawfords LGT, Block's Gumball, and david's RSTi..."
-Random dude on SoCal Subie

Offline onemanzu

  • Elite Member
  • *****
  • Posts: 1980
Re: Hesitation in my 2002 Impreza 2.5RS
« Reply #1 on: February 24, 2012, 08:56:53 AM »
My guess is a vacuum leak, or a bad air intake sensor or something around those parts. The Cam noise is what leads me to believe a vacuum leak

Offline PhamilySedan

  • Elite Member
  • *****
  • Posts: 1349
    • http://www.nebraska-subaru.com
Re: Hesitation in my 2002 Impreza 2.5RS
« Reply #2 on: February 24, 2012, 10:33:37 AM »
That could be a possibility.  I'll look around to see if there are any missing connections.  I'll report back if this works.  Hopefully this thread will help someone in the future because this problem is a PITA!

"Yet another reason I wish I was rich. I would own Crawfords LGT, Block's Gumball, and david's RSTi..."
-Random dude on SoCal Subie

Offline Finn

  • Member
  • **
  • Posts: 56
Re: Hesitation in my 2002 Impreza 2.5RS
« Reply #3 on: February 28, 2012, 09:57:29 PM »
did ya find out what it was? im curious

Offline rallyfan555

  • Sr. Member
  • ***
  • Posts: 562
  • 2001 2.5rs sedan Black Diamond Pearl
    • MyLifeAtSpeed.com
Re: Hesitation in my 2002 Impreza 2.5RS
« Reply #4 on: February 28, 2012, 10:06:23 PM »
Replace your PCV valve, located on the top of the intake manifold, this is a cheap fix that may help with the vacuum issues.
*2001 2.5rs sedan Black Diamond Pearl
*2001 Outback H6 LL Bean Edition
*1999 Legacy Outback Black Diamond Pearl- Sold
*2003 WRX sedan World Rally Blue-Sold
*1999 2.5rs coupe Rally Blue Pearl - Sold

Offline onemanzu

  • Elite Member
  • *****
  • Posts: 1980
Re: Hesitation in my 2002 Impreza 2.5RS
« Reply #5 on: February 28, 2012, 10:37:46 PM »
did ya find out what it was? im curious

Me too! I want to know.

Offline PhamilySedan

  • Elite Member
  • *****
  • Posts: 1349
    • http://www.nebraska-subaru.com
Re: Hesitation in my 2002 Impreza 2.5RS
« Reply #6 on: March 02, 2012, 05:32:49 PM »
I'm persuaded that it's the upstream o2 sensor that is causing my problems.

There is some good information in my thread on NASIOC.  http://forums.nasioc.com/forums/showthread.php?t=2315412

"Yet another reason I wish I was rich. I would own Crawfords LGT, Block's Gumball, and david's RSTi..."
-Random dude on SoCal Subie

Offline csmiller18

  • Member
  • **
  • Posts: 169
Re: Hesitation in my 2002 Impreza 2.5RS
« Reply #7 on: April 02, 2012, 01:20:50 AM »
Get'r running right?
2005 WRB STi
2008 YAMAHA R6
2005 HONDA TRX450R