Author Topic: 02 wrx running 20lbs of boost after cel  (Read 3156 times)

Offline allskate03

  • Member
  • **
  • Posts: 500
02 wrx running 20lbs of boost after cel
« on: April 22, 2012, 10:42:59 PM »
i was driving on the highway at about 55mph in 5th gear went to pass a car and once i started to accelarate my car spuddered and then the cel came on. this has happened one other time ago in dec. i was checking to make sure it was still building boost but it would jump up to 20lbs according to my boost gauge it has never gone that high before normally it is just under 15lbs. when i got home i disconected the battery to clear the light, then took it out and it is now constantly maxing out at 20lbs every time i would do a pull. when this happened the first time and i disconected the battery i was boosting normaly. so i dont want to damage the turbo or engine. i have never had the code pulled because it has always been on a sunday night
the car is a 2002 wrx with 60k miles
has a sti up pipe, sti top mount, 3in turbo back, k&n filter in a hacked stock air box, and a hks ssq bov.
]

Offline Bogey

  • Elite Member
  • *****
  • Posts: 2535
Re: 02 wrx running 20lbs of boost after cel
« Reply #1 on: April 22, 2012, 11:31:23 PM »
I started getting boost spikes after I had my car fixed last time.  Exactly how you got yours on the interstate passing a truck.  When my car was fixed they replaced some of the intake system that had issues and was cracked.  RG pulled my codes and it said I was over boosting.  I still need to have Tank retune me to fix it.  I have just been easy on my car since then.  I would take it easy on your ride until you can have someone take a look at it.  Motors arent cheap ;).  I would get ahold of Tank to check out your tune.

Offline 99STM

  • Elite Member
  • *****
  • Posts: 2888
Re: 02 wrx running 20lbs of boost after cel
« Reply #2 on: April 22, 2012, 11:36:20 PM »
That is not a problem with the tune. Check your the vacuum lines to your wastegate to see if they are cracked. Knowing the code from the CEL would help a lot.
-Shawn

Offline TeknoCop

  • Elite Member
  • *****
  • Posts: 3160
Re: 02 wrx running 20lbs of boost after cel
« Reply #3 on: April 23, 2012, 12:22:20 AM »
That is not a problem with the tune. Check your the vacuum lines to your wastegate to see if they are cracked. Knowing the code from the CEL would help a lot.

+1. 

Offline allskate03

  • Member
  • **
  • Posts: 500
Re: 02 wrx running 20lbs of boost after cel
« Reply #4 on: April 23, 2012, 12:01:57 PM »
the code was p0244 i got it to throw today and used a scan tool to pull it. before it had the code come up my boost gauge hit almost 30lbs of boost im starting to think the gauge may be broke.
]

Offline kevinmfb

  • Elite Member
  • *****
  • Posts: 4083
  • 09 OBP WRX Hatch
Re: 02 wrx running 20lbs of boost after cel
« Reply #5 on: April 23, 2012, 12:09:20 PM »
there could be a few culprits.  If you're over boosting it could be BCS, vacuum hoses, tune.


My car would over boost occasionally but I'm running a Grimmspeed 3-port ebcs and a manual boost controller with a tune.  Holds fine :)

Offline allskate03

  • Member
  • **
  • Posts: 500
Re: 02 wrx running 20lbs of boost after cel
« Reply #6 on: April 23, 2012, 03:34:42 PM »
figured out the prob had a hole in the line that goes under the intercooler into the waste gate
]

Offline C.J.

  • Elite Member
  • *****
  • Posts: 1840
Re: 02 wrx running 20lbs of boost after cel
« Reply #7 on: April 23, 2012, 05:52:17 PM »
Time to step it up.  MBC. :)

Offline 99STM

  • Elite Member
  • *****
  • Posts: 2888
Re: 02 wrx running 20lbs of boost after cel
« Reply #8 on: April 23, 2012, 06:52:55 PM »
figured out the prob had a hole in the line that goes under the intercooler into the waste gate

Damn I'm good
-Shawn

Offline kevinmfb

  • Elite Member
  • *****
  • Posts: 4083
  • 09 OBP WRX Hatch
Re: 02 wrx running 20lbs of boost after cel
« Reply #9 on: April 23, 2012, 08:04:45 PM »
Start small and work your way up the expense ladder  ;)
MBC is always a good idea too...and cheap.
« Last Edit: April 24, 2012, 06:05:25 AM by kevinmfb »

Offline Bogey

  • Elite Member
  • *****
  • Posts: 2535
Re: 02 wrx running 20lbs of boost after cel
« Reply #10 on: April 23, 2012, 10:42:25 PM »
My issue was a cracked inlet with a hole in it.  That is why I need a retune.  Glad you got yours fingered out. 

Offline 99STM

  • Elite Member
  • *****
  • Posts: 2888
Re: 02 wrx running 20lbs of boost after cel
« Reply #11 on: April 24, 2012, 09:16:22 AM »
My issue was a cracked inlet with a hole in it.  That is why I need a retune.  Glad you got yours fingered out.
Inlet...as in turbo inlet?? That will not cause overboost, that is just a vacuum leak. You have problems lying elsewhere.
-Shawn

Offline Aki

  • Moderators
  • Elite Member
  • *
  • Posts: 4556
Re: 02 wrx running 20lbs of boost after cel
« Reply #12 on: April 24, 2012, 10:06:21 AM »
IIRC, he's referring to an intake mani.

Offline Bogey

  • Elite Member
  • *****
  • Posts: 2535
Re: 02 wrx running 20lbs of boost after cel
« Reply #13 on: April 24, 2012, 11:25:56 PM »
No and yes, when my car was tuned it was having trouble getting the desired boost and we couldnt figure out why.  After messing with all sorts of possibilities, the consensus was that it may had been my boost controller, so we put a 3port on and it helped, but still couldn't get it there.  Nothing that was done to it would get it there, so Tank did the tune according to how my car was setup and I was okay with that.  Then when they were doing my fuel stench fix, they found that my inlet was all cracked and I had must have had some other issue.  My car was pulling way hard after that, then about a week later I overboosted.  So, I had some vacuum/air flow issues going on that were fixed.  My tune that I had was setup before the flow issue was all gooder, so it is looking like I need to get it remapped to fix it.  I have been taking it easy on it since and had no issues.  When my car threw the code I was going 55 and floored it to pass a semi, then all of a sudden my car choked and threw codes.  Russ pulled them and it was for over boosting, I don't remember what the actual code pulled was though. 

Offline 99STM

  • Elite Member
  • *****
  • Posts: 2888
Re: 02 wrx running 20lbs of boost after cel
« Reply #14 on: April 25, 2012, 12:55:46 AM »
Did you ever boost leak test the car? A boost leak obviously wouldn't cause overboosting but if you are having a list of problems with the car it is definitely something to do.

Like I said, a cracked turbo inlet is not going to cause overboosting. If tank set your target boost to 18-20 or whatever, and you are hitting 25 plus, that is a problem with the wastegate lines, restrictor pill, or something along those lines. I do not have any personal experience with restrictor pills but I have had problems with wastegate lines. If your wastegate doesn't open properly, it will just allow the turbo to spin as fast as possible. 30psi overboosting with no wastegate will probably make the car feel less powerful than 15 psi on a functioning setup.

I'm not trying to tell anybody their wrong or anything I'm just saying that if I wanted to bet on something, it'd be on the fact that your leaking turbo inlet is not causing over boost. Tank can retune it for you, I'm sure he's more than willing to and I'd bet that it will run much better at partial throttle/idle but I highly doubt it's going to fix your issue.

/2 cents
« Last Edit: April 25, 2012, 12:57:27 AM by 99STM »
-Shawn

Offline Bogey

  • Elite Member
  • *****
  • Posts: 2535
Re: 02 wrx running 20lbs of boost after cel
« Reply #15 on: April 26, 2012, 02:25:00 PM »
No worries, any input is good.  At this point I just havent had the time to have Russ fully look at it.  It happened twice and then it hasnt happened since.  No leak test.  Russ took a quick look when he pulled the code, but couldnt find anything out of place.  It has been running fine so until I can get it in for a better looksy I just drive it normal with no racing around.