Author Topic: Electrical Issue?  (Read 60 times)

Offline crdomaha

  • Newbie
  • Posts: 5
Electrical Issue?
« on: October 22, 2017, 06:23:52 PM »
I have a 2007 Outback.  I recently started having some electrical issues.  One night, my cruise control light started blinking randomly.  The next morning, a couple of other lights started coming on (ABS, brake, etc.)  The engine started to get sluggish on me when accelerating before it finally died.  I had the alternator replaced as I was told that was the issue.  While that was getting fixed, a code popped up for an O2 sensor, which I replaced.  My friend has a code scanner and once the sensor was replaced, we went to clear the check engine light and another one popped up as a cylinder misfire.  Today, the check engine light has been going back and forth between flashing and staying on.  Between driving to Target and back home, the cruise control light started flashing again.  Is there some type of spark plug/wire issue here or is this something bigger?  Thank you ahead of time for any advice.

Offline Reverend

  • Elite Member
  • *****
  • Posts: 1587
  • Higgins Blue
    • All We'll Drive
Re: Electrical Issue?
« Reply #1 on: October 23, 2017, 07:59:46 AM »
Typically having multiple lights on your dash (especially a cruise control light) is a sign that a bad code has been thrown.  Your friend with the code scanner should be able to tell you what it's on for again.

Offline crdomaha

  • Newbie
  • Posts: 5
Re: Electrical Issue?
« Reply #2 on: October 30, 2017, 08:27:47 AM »
It was an easy fix.  I had a cylinder 1 misfire.  I replaced the spark plug and boy, was that gap huge.

Offline Reverend

  • Elite Member
  • *****
  • Posts: 1587
  • Higgins Blue
    • All We'll Drive
Re: Electrical Issue?
« Reply #3 on: October 31, 2017, 08:45:43 AM »
Glad it was a relatively simple fix.  I had a misfire on an older Subie and it ended up being a burnt valve.